Rails Upgrade Checklist

Stuck on Rails 2.3 (or earlier) and not sure what to do?

This step by step guideline is your friend. Each step is doable, so you can make this happen!

Q: Wait now, What is this?

A: A list, nay, a Framework for upgrading Rails Apps to version 4.0

2016 Disclaimer

I need to work on versions 4.1, 4.2, and getting to 5.0. Pull-Requests accepted,
but you may just want to use RailsDiff if you're already on 4.0.

What version of Rails are you on?

Getting to 2.3

Getting to Rails 3.0

Getting to Rails 3.2

Getting to 4.0

Let's talk about your database:

Let's talk about deprecated gems:

Let's talk about how to prevent this from happening in the future:

Does this process suck?

YAY -- What should you do with this list?